The Main Menu Bar

<< Click to Display Table of Contents >>

Navigation:  FlexPDE Help > Getting Started >

The Main Menu Bar

Previous pageReturn to chapter overviewNext page



The items of the main menu present many of the conventional functions of graphical applications.  The availability and precise meaning of these menu items depends on the current state of processing of the problem.  We summarize the menu items here, and describe them in more detail in the following sections.



The "File" menu item allows you to begin operation by opening a problem descriptor file, importing a DXF file, importing an OBJ file, or viewing previously stored graphical output from a FlexPDE run.  It also allows you to save your work or exit the application. These operations are performed using standard dialogs of the computer operating system. (See "The File Menu")


This menu contains an assortment of functions that may be performed during the generation and running of a problem descriptor, such as running the script or switching between edit and plot modes.  (See "The Controls Menu")


When a stored FlexPDE graphics file has been opened, the View menu item will present a menu of options for controlling the display of the stored images. (See "Viewing Saved Graphic Files")


While a problem is being run, the Stop menu item will display a selection of termination strategies of various levels of urgency.  (See "The Stop Menu")


When a descriptor is being edited, this menu provides standard editing commands. (See "Editing Descriptor Files")


The Help menu contains five items as shown below:


On Windows, the "Help" sub-item will initiate the help system. On Mac and Linux, you must manually initiate your browser and direct it to "Help | Html | Index.html" in the FlexPDE installation directory.
The "Preferences" sub-item allows you to inspect or modify the various FlexPDE preferences.  (See "Preferences Window")
The "Register FlexPDE" sub-item brings you to the License Registration Preferences tab and allows you to inspect or modify the FlexPDE license registration.  (See "License Registration Tab")
The "Read License Agreement" sub-item displays the End-User License Agreement.
The "About FlexPDE" sub-item redisplays the About banner. Note that on Mac this item appears in the FlexPDE "Application" menu.